Apple’s outdated iOS versions are being removed from the WhatsApp device requirements list in October, the Meta-owned company has announced.

WhatsApp is ending support for iOS 10 and iOS 11 later this year, meaning outdated iPhone hardware will no longer support the encrypted messaging app.

The WhatsApp service shall stop functioning after October 24, 2022, with the Meta-owned company requiring all users to be running iOS 12 or newer.

People who are still using iPhones that don’t run on iOS 12 will need to upgrade to one of the newer iPhone models or stop using the app on their old phones.



Table of Content

WhatsApp is ending support for iOS 10 and iOS 11

WhatsApp’s device requirements change over time as some devices get outdated and are no longer supported, and this is one of those cases. If you use WhatsApp on an iPhone 5 or iPhone 6s and later, you should update the device to at least iOS 12 in order to continue using WhatsApp. As always, the company recommends using the latest iOS version to get up-to-date security protections and fixes.

WhatsApp Help Center:

To keep up with the latest advances in tech, we routinely stop supporting older operating systems to point our resources to supporting the latest ones. If we stop supporting your operating system, you’ll be notified and reminded a few times to upgrade your device to continue using WhatsApp.

Owners of older iPhones that cannot run iOS 12 will need to upgrade to a newer model capable of supporting at least iOS 12. If you’re in that boat, you should back up your WhatsApp data to iCloud so you could restore your chat archive on your new iPhone. The app has also dropped support for some versions of Android. 

Which iPhones are on WhatsApp’s device compatibility list?

While WhatsApp currently runs on iOS 10 and later, the minimum system requirements will change in October when the company cuts off iOS 10 and iOS 11. And as soon as iOS 12 becomes the new minimum requirement for WhatsApp, the app will require the same iPhone models as iOS 12 does (meaning all iPhones from the iPhone 8 and later).

iOS 12 also runs on the sixth-generation iPod touch and newer. But can you use WhatsApp on Apple’s discontinued media player? The answer is no because the iPod touch lacks SMS or call capability which is required to properly set up a new WhatsApp account. WhatsApp currently does not support setting up new accounts on Wi-Fi-only devices though that might change in the future.

Post a Comment

Previous Post Next Post